Jump to content
GPS навигатор СитиГИД
Joss

Релиз СитиГИД 7.8 SP для WinCE

Recommended Posts


В папке СГ файлы *.upd они нужны или можно удалить?
Можно удалить. Это файлы корректуры карт. При первой же связи с сервером появятся новые. А можно и не удалять. Короче, пофиг. :)

Share this post


Link to post
Share on other sites

Эвона как, просто смотрю файлы с пробками в отдельной папочке лежат. а UPD брошены валяться просто так. Неакуратненько.

Share this post


Link to post
Share on other sites

4Q!!, Издержки установки не начисто

Share this post


Link to post
Share on other sites

У меня сегодня тоже начались необъяснимые вращения дельтоплана. Начались на Дыбенко и продолжались на протяжении Дальневосточного до Крыленко. Точка местонахождения улетала куда-то во дворы и маршрут начинал строиться из дворов, программа постоянно меняла направления движения, то в сторону моста А. Невского, то в сторону Володарского, не критично, но если бы ехал первый раз по этому маршруту, то были бы большие проблемы, тем более в час пик.

У меня эти проблемы появились с установкой 7.8. Навигатор, Тексет-800 вт служит уже много лет и проблем ни  с одной программой (3.8, 5.0,предрелиз 7.0, 7.2, 7.7 не было. А сейчас 1 - 2 сбоя по пути с работы. Также проблемы при включении программы связь со спутниками  долго не устанавливается, когда надоедает перегружаться и ждать - перехожу на "Прогород". Связь со спутниками сразу восстанавливается - выключаю и перехожу на СГ. Связь со спутниками сохраняется, но наступают "глюки" - карта начинает вращаться, "вертолет" устанавливается на крыше домов, спутник становиться желтым (голосовое сопровождение маршрута продолжатся как не странно). Проблем с "голосом" не было. Программу 7.8 sp устанавливал "начисто".

Как считаете - где собака порылась???

Share this post


Link to post
Share on other sites

в файле CityGuideVoicerudefaultin0150.ru.wav присутствует малозаметный щелчок, который изрядно мне надоел, я его убрал конечно, но может его поправить глобально :)

Share this post


Link to post
Share on other sites

а у всех работает кнопочка в избранном с флажком финиша рядом с названием пункта списка избранного? У меня срабатывает иногда с 1 раза, иногда со 2-го, а иногда и с четвёртого ...

Share this post


Link to post
Share on other sites


а у всех работает кнопочка в избранном с флажком финиша рядом с названием пункта списка избранного? У меня срабатывает иногда с 1 раза, иногда со 2-го, а иногда и с четвёртого ...

+1. Тоже самое подметил.

Share this post


Link to post
Share on other sites

+1 тоже

 

Вот так сегодня вдруг исчез маршрут во время движения

i-33.jpg

 

А вот так пошел гулять дельтаплан после поворота на Лесной

 

i-34.jpg

 

Ну и разворот карты при остановке на перекрестке

 

i-35.jpg

Share this post


Link to post
Share on other sites

arcad, попробуйте увеличить в настройках маршрута значение "пересчет при удалении". У Вас явные проблемы с точностью работы GPS-модуля.... 

Share this post


Link to post
Share on other sites


проблемы при включении программы связь со спутниками долго не устанавливается,

Парни, у кого плохая связь, проверяйте в настройках параметры порта GPS. Выставляйте точные значения своего порта (номер и скорость). WinCE программа, как правило, ставит первую скорость по соответствующему протоколу (которая не всегда совпадает с паспортной).

На моем ГУ параметры Com2, 9600.

Программа на автомате всегда определяет Com2, 4800. При этом ловит, но не совсем уверенно и быстро.

Когда выставляю паспортные данные - все просто замечательно.

  • Upvote 1

Share this post


Link to post
Share on other sites

Процитирую самого себя, но уже с картинкой!

 

К глюкам. Ещё один, который я заметил ещё на 7.6 (было 1 раз поэтому тогда не писал об этом):

Еду по маршруту, все проложено-пробко-включено. Связь есть.

Потом где-то на 1 секунду появляется на экране прямая маршрута дополнительная, С левого верхнего края экрана вниз, в центр "поперёк карты" без привязки к старту/финишу.

Потом исчезает. Моя скорость была 30-40 км/ч. Я уже наготове - вдруг опять появится! Буквально через несколько сек останавливаюсь на светофоре и опять появляется - успеваю сделать снимок экрана. Исчезает - и больше я пока не видел.

 

 

А вот вчерашний тексто-чат, полезная штука, хоть чем-то себя занять в пробке можно. Сиди-читай, так и повесть написать можно:

 

Share this post


Link to post
Share on other sites

Парни, у кого плохая связь, проверяйте в настройках параметры порта GPS. Выставляйте точные значения своего порта (номер и скорость). WinCE программа, как правило, ставит первую скорость по соответствующему протоколу (которая не всегда совпадает с паспортной).

На моем ГУ параметры Com2, 9600.

Программа на автомате всегда определяет Com2, 4800. При этом ловит, но не совсем уверенно и быстро.

Когда выставляю паспортные данные - все просто замечательно

Попробую.

 

 

 

А вот вчерашний тексто-чат, полезная штука, хоть чем-то себя занять в пробке можно. Сиди-читай, так и повесть написать можно:

attachicon.gif2013-06-11_(18-13-41).PNG

 

Вчерашний пробковорот просто - нечто. Читал, ржал... действительно спасает от скуки.

Edited by arcad

Share this post


Link to post
Share on other sites

Эх, всё же пропадает звук. Сегодня много катался по СПб, пропадает очень забавно: говорит-говорит (много, и часто не по делу)), а потом замолкает на минут на 5, и опять говорит. С устройством ничего не делал, не ресетил, но от маршрута отклонялся. Когда уже починится-то печальное полу-отсутствие Татьяны?

Share this post


Link to post
Share on other sites

Чего-то я ничего не пойму.

ДПОИ у меня то показываются, то не показываются вовсе.

Причём показ ДПОИ исчезает и появляется после перезапуска СГ, иногда разница во времени между показом и не показом может составлять минуты.

Пробки показываются всегда.

Редактировал файл ресурсов, убирал отображение текста на экране, может с этим связано?

В связи с этим вопрос: Каким архиватором упаковывают файл ресурсов разработчики?

Например splash.rsr заставка отображается нормально, перепаковывал 7zip 9.20.

Share this post


Link to post
Share on other sites

Нет, они должны быть слева сразу над нижним баром. Собственно, глюка давным-давно известная, но рядом с тем, что исправлялось, не сочтенная достойной срочного исправления. Ну, позанудничать можно (занудам), но на два скрина -- как-то чересчур, на мой вкус. Сродни еще одной одиозной личности, которая до сих пор требует пресс-релиз на тему торможения 7.8 на карте 10.1 :)

ну я о таком баге не слышал, вот и озвучил.

Никто кроме одного форумчанина не откликнулся. Joss же только слегка спросил и ничего более не написал.

Я надеялся, что это может быть легко исправлено и надеюсь, что будет исправлено.

Написали бы Бета-тестеры - репорт оформлен и будет исправлен в следующем релизе.

Мне лично не удобно при описанной ситуаци не видеть заряды и наличие связи!

Share this post


Link to post
Share on other sites

А у меня после выхода из СитиГида пропадают все друзья из списка.

Если просто навигатор выключить, то всё нормально.

 

Lexand si-512 и texet 606

 

Приходится заново вбивать и приглашать.

Edited by Borodator

Share this post


Link to post
Share on other sites


А у меня после выхода из СитиГида пропадают все друзья из списка.

Списка Друзей в навигаторе нет, он каждый раз подгружается с сервера. Иногда это занимает определенное время. Надо просто чуть подождать.

  • Upvote 1

Share this post


Link to post
Share on other sites

Список друзей закачивается с сервера.

Отправлено с моего ZTE-BLADE через Tapatalk

  • Upvote 1

Share this post


Link to post
Share on other sites

А у меня после выхода из СитиГида пропадают все друзья из списка.

Если просто навигатор выключить, то всё нормально.

 

Lexand si-512 и texet 606

 

Приходится заново вбивать и приглашать.

Прочитайте и напишите в ветку "не работает функция друзья". Но о таком слышу впервые. Функция друзья работает стабильно, если только не ведутся работы на сервере.
  • Upvote 1

Share this post


Link to post
Share on other sites

А у меня после выхода из СитиГида пропадают все друзья из списка.

Если просто навигатор выключить, то всё нормально.

 

Прочитайте и напишите в ветку "не работает функция друзья". Но о таком слышу впервые. Функция друзья работает стабильно, если только не ведутся работы на сервере.

 

Скорее всего, под "просто выключить навигатор" имелось в виду "увести в спящий режим, не выключая СГ". В этом случае конечно список в нем остается - программа-то продолжает работать. 

А в остальном - советы уже даны выше.

  • Upvote 1

Share this post


Link to post
Share on other sites

Списка Друзей в навигаторе нет, он каждый раз подгружается с сервера. Иногда это занимает определенное время. Надо просто чуть подождать.

Ну да, подгрузились пробки и появились друзья.

Получается, что без пробок у меня нет друзей  :(  :(  :(

:D

 

Всем спасибо.

Share this post


Link to post
Share on other sites


Получается, что без пробок у меня нет друзей

По ходу в Питере пробки и есть Ваши друзья :D :D

  • Upvote 1

Share this post


Link to post
Share on other sites

По ходу в Питере пробки и есть Ваши друзья :D :D

+100500 :D

Share this post


Link to post
Share on other sites

По ходу в Питере пробки и есть Ваши друзья :D :D

Извращенцы  :angry:

 

Поставил в настройках на GPS порт COM1 и скорость 14400, вроде лучше стало с позиционированием. Поеду с работы проверю окончательно.

Share this post


Link to post
Share on other sites

Поставил в настройках на GPS порт COM1 и скорость 14400, вроде лучше стало с позиционированием. Поеду с работы проверю окончательно.

 

Насколько я понимаю, протокол NMEA (в данном случае, формат передачи навигационных данных) подразумевает передачу данных по последовательному порту со скоростью (по умолчанию) 4800 бод.

С момента покупки у меня на texete такая скорость и стоит, и всё работает нормально (кстати, не нашел, как можно в самом навигаторе (не в СГ) посмотреть/установить эту скорость).

 

 

Думаю, что при задании другой скорости при старте СГ "управляет микросхемой" сом-порта для установки нужной скорости. Однако возможная "несовместимость" железа может привести к тому, что это управление на отдельных моделях навигаторов может происходить криво. Поэтому, наверное, целесообразно ставить скорость "по умолчанию", т.е. 4800. Этой скорости вполне хватает для передачи необходимой информации от gps раз за секунду.

 

З.Ы. Всё это из предположения, что СГ получает информацию от GPS по протоколу NMEA. Вроде это так, но на 100% не уверен

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...