Jump to content
GPS навигатор СитиГИД
Joss

СитиГИД 9.0 для Android

Recommended Posts

Попробуйте Llama https://play.google.com/store/apps/details?id=com.kebab.Llama

Правило:

Условие - Зарядка->Работает от аккумулятора

Действие - Завершить приложение (root)->CityGuide

Нормально убивает приложение, правда, если включено отображение ярлыка в статусбаре, он остаётся висеть, но сг в фоне в это время уже точно нет. Если ярлык мешает - его отключить можно.

Отправлено с X2 через Tapatalk

Share this post


Link to post
Share on other sites
2 часа назад, nsgdima сказал:

И по GPS, начиная с 8й версии обычным явление стало что после запуска СитиГИД не видит спутников, вообще и никак, хоть пол часа сиди, закрываем СитиГИД, запускаем по новой и вуаля, спутники найдены моментально ... Аналогично бывает после запуска ошибка позиционирования метров 200, перезапускаем СитиГИД и все отлично ... После поворота СитиГИД продолжает рисовать еще секунд 10 как будто не поворачивал а продолжил ехать прямо ... соответсвенно регулярно успевает перестроить маршрут и начинает давать команды уже по новому, что вгоняет в ступор, пока не посмотришь на экран и не поймешь что он тупо ошибается с положением ... и ошибается оно от версии к версии все больше и больше :( аналогично с прыганием по улицам, ну усвойте вы наконец что невозможно проехав 20км по КАД, вдруг перепрыгнуть на дорожку в поле рядом с КАД, ну не блоха автомобиль, не может он прыгать по улицам ... раньше он хотя бы говорил "маршрут изменился" теперь хрен, "самовольный" уход с маршрута оно теперь не озвучивает :( Картина одинакова на нескольких устройствах, ни в одной другой программе подобным проблем нет ...

 

Какие жуткие вещи вы рассказываете:ph34r:

Я думаю, что вам надо сменить автомобиль  разобраться, что у вас за чертовщина. Если в автомобиле включены какие-нибудь видеорегистраторы и пр., попробуйте проехать с СГ, не включая их. Похоже что-то у вас сигнал спутников забивает. Типа GPS test не запускали, что он показывает

Share this post


Link to post
Share on other sites
5 минут назад, svlad2012 сказал:

Какие жуткие вещи вы рассказываете:ph34r:

Я думаю, что вам надо сменить автомобиль  разобраться, что у вас за чертовщина. Если в автомобиле включены какие-нибудь видеорегистраторы и пр., попробуйте проехать с СГ, не включая их. Похоже что-то у вас сигнал спутников забивает. Типа GPS test не запускали, что он показывает

У него "Картина одинакова на нескольких устройствах, ни в одной другой программе подобным проблем нет ..."

Если "несколько устройств" - в том же авто, то надо разбирать/собирать авто.

Но "ни в одной другой".... Если эти другие используют жпс, то чертовщина получается...) И без ДиОса здесь не разобраться)

Share this post


Link to post
Share on other sites
2 часа назад, nsgdima сказал:

В целом вывод один и он грустный - программа все больше и больше из удобного инструмента превращается в продукт ради продукта, ездить изредка поглядывая в экран становится почти невозможно, в экран надо вглядываться, на него надо смотреть и видимо любоваться ... надо постоянно вникать что же оно имело ввиду :( для стендовой демонстрации возможно это красиво, но вот ездить с этим становится практически невозможно :( 

В целом весь Ваш рассказ про мытарства СИТИГИДа со спутниками наводит только на одну мысль - пора менять девайс. Все, что Вы описали выше, больше подходит к проблеме работы самого железа (GPS модуль - аппаратная часть). Примерно такие вещи наблюдались в ТЕХЕТ-ах, с еще  более ранними версиями СГ, когда у них начинало сдыхать железо или аккумулятор. Увы - ничего не вечно под луной.

Share this post


Link to post
Share on other sites

Рут нормальный, остальные проги таскер закрывает на ура, СитиГИД закрывается что таскером, что ситигидстартером один раз из 10 :( аппаратов несколько, две супры 7 дюймов с 4.2 дроидом, galaxy S, asus padFone, пара китайцев на 4м андроиде, везде картина абсолютно одна и таже :( глушу двигатель, питание отключается, экран гаснет, вроде все правильно, но при включении экрана видим что передача данных не отключена, а СитиГИД висит в "трее", если оставить в таком виде, то к концу рабочего дня от аккума остается процентов 70, а заряжается в машине оно весьма тоскливо :( телефоны нормально, а планшету явно не хватает 2х ампер чтобы и работать c ситигидом и заряжаться, в итоге домой приезжаю уже на грани фола, заряд 35-45%, если с пробками то 25-30 :( причем таскеру удается снести СитиГИД только экстремальным способом, любым другим только сворачивает ...

Share this post


Link to post
Share on other sites

Заинтриговал) Не могу найти разумный ответ на вопрос "Почему бы просто не выключать девайсы?")

Share this post


Link to post
Share on other sites

Регистратор да есть, но он никак не мешает ни IGO, ни яндексу, ни навителу ... почемуто ... мало того старая версия на мобильной винде нормально работает, только экранчик там маленький и тачик почти помер :( проблемы с позиционированием проявляться стали с 8й версии и в 9й только усугубились, с чем связано не знаю, аппаратов перепробовал с десяток разных, и таки на разных машинах, картина одна и таже :(

GPS test не пробовал, StatusGPS находит спутники всегда за 3-5 сек, если не включался неделю, то секунд 10-15, точно также как СитиГИД при повторном запуске ... я уже почти на автомате запускаю СитиГИД, закрываю и запускаю еще раз, после это и точность нормальная и спутники находятся практически мгновенно ... яндекс с первого раза спутники находит ...

Share this post


Link to post
Share on other sites

Во! Новая вводная "на разных машинах". Авто разбирать не придется)

Бредовая мысль - а по какому адресу включается утром СГ (улица, дом)?

И еще вопрос к Joss-у:

Михаил, а СГ что раньше обрабатывает - пробки или позиционирование? У аффтара, похоже, все девайсы двухядерные.

Share this post


Link to post
Share on other sites

Утром, чаще всего, СПб, конец Планерной улицы, летом Дорога Жизни Ваганово, вечером СПб Софийская ул. вблизи пересечения с КАД, и утром и вечером нормальный запуск почти всегда со второй попытки, первый раз либо не видит спутники, либо дикая погрешность, времсто Планерной показывает на ЗСД

Аппараты одноядерный дроид 2.3, двуядерные 4.1-4.2 и два планшета 4.2, один двуядерный, другой четырехядерный.

Share this post


Link to post
Share on other sites
11 минуту назад, nsgdima сказал:

Утром, чаще всего, СПб, конец Планерной улицы, летом Дорога Жизни Ваганово, вечером СПб Софийская ул. вблизи пересечения с КАД, и утром и вечером нормальный запуск почти всегда со второй попытки, первый раз либо не видит спутники, либо дикая погрешность, времсто Планерной показывает на ЗСД

Аппараты одноядерный дроид 2.3, двуядерные 4.1-4.2 и два планшета 4.2, один двуядерный, другой четырехядерный.

Версия такая:

"Первый раз либо не видит спутники" - это еще ни жпс, ни сигнал опсоса не получены, поэтому нет позиционирования даже по БС.

"Либо дикая погрешность" - жпс еще нет, а от опсоса позиционирование по БС уже есть.

Потом Вы закрываете СГ - а это теперь несколько секунд. Потом Вы запускаете СГ - а это еще два раза по несколько секунд. За это время девайс получил жпс, а СГ его радостно скушал)

На двухядерных аппаратах это нормально)

Share this post


Link to post
Share on other sites

Хорошо спрошу в этой теме.

При каком колличестве активных пользователей сг появляется виджет? 

При увеличении масштаба до 1:750000, на экране появляются красные(чаще всего красные, но бывает что просто цвет меняется) следы, которых не видно до этого предела. Поднимаясь выше до 1:1500000, добавляются ещё следы.  Если на этих местах где они появились, проложить маршрут с окрасом цвета пробок, то он остается зелёным. Это баг или фича? 

Share this post


Link to post
Share on other sites

Nsgdima:

Добавлю: как я догадываюсь, у Вас запускается программа видеорегистратора, в которой в настройках включено "запускать при подключении питания". Т.е. регистратор запускается и включает жпс. И пока потом Вы производите манипуляции с СГ - регистратор уже раскрутил жпс)

Share this post


Link to post
Share on other sites

Регистратор отдельное устройство, если и может как то влиять, то только на уровне электромагнитных помех

Re:  Версия такая:

Может конечно и так, но во первых если не перезапускать, то спутники оно не найдет никогда, ну по крайней мере за 30-40 минут не находит, во вторых с другими программами такого нет, они находят спутники нормально и двуядерность им совершенно не помеха ... Ну и насчет координат по опсосу - когда позиционирование идет по БС нет движения, а тут идет четкое движение, с правильной скоростью, только с ошибкой в 200-500 метров ...

Share this post


Link to post
Share on other sites
В 28.10.2015, 7:29:48, dadsnake сказал:

Добрый день!

Что за проблема и как её решать?

Заглянуть в логи - не очень понимаю,  что это означает...   

А, понял, есть папка log, там errors.txt...

Вот:

 

>
2015-10-28 07:36:10 start log
lic datdata
 

Т.е. СГ не работает? Ну у меня такая же проблема, о ней знают, но пока не исправили, откатывайтесь до 8-ки.

Share this post


Link to post
Share on other sites
44 минуты назад, samsu сказал:

При каком колличестве активных пользователей сг появляется виджет? 

Появление колобуха не зависит от количества пользователей. Он появляется только для регионов, для которых его появление прописано. Алматы не относится к их числу.

На обзорных масштабах маршрут цветом пробок не выделяется.

Edited by /DiOs

Share this post


Link to post
Share on other sites
29 минуты назад, nsgdima сказал:

Ну и насчет координат по опсосу - когда позиционирование идет по БС нет движения, а тут идет четкое движение, с правильной скоростью, только с ошибкой в 200-500 метров ...

Я такое припоминаю на каком-то старом СГ. Не помню уже версию даже. Возможно 7-ка. И аппарат был другой (HTC Desire). Аппарат был рутирован, да еще и на кастомной прошивке.  Потом вообще сдох. Может дело где-то в каких-то настройках системы? Я там помнится игрался всякими GPS Fix и т.п. Это правда, было пару раз, потом вроде прошло само собой.

Share this post


Link to post
Share on other sites
38 минуты назад, nsgdima сказал:

Регистратор отдельное устройство, если и может как то влиять, то только на уровне электромагнитных помех

Re:  Версия такая:

Может конечно и так, но во первых если не перезапускать, то спутники оно не найдет никогда, ну по крайней мере за 30-40 минут не находит, во вторых с другими программами такого нет, они находят спутники нормально и двуядерность им совершенно не помеха ... Ну и насчет координат по опсосу - когда позиционирование идет по БС нет движения, а тут идет четкое движение, с правильной скоростью, только с ошибкой в 200-500 метров ...

"Не верю!" (с) !!

На всех девайсах и на разных машинах?! Дайте посмотреть!)

Share this post


Link to post
Share on other sites

Re:  Дайте посмотреть!)

Да запросто :) будете со мной кататься? Могу на след неделе поставить второй рег снимать работу ситигида, потому выложу ссылку на триллер ...

Re:  Может дело где-то в каких-то настройках системы?

Аппаратов несколько ... один из них абсолютно новый четырехядерный планшет супра, картина абсолютно таже :(

Edited by nsgdima

Share this post


Link to post
Share on other sites
57 минут назад, nsgdima сказал:

Аппаратов несколько ... один из них абсолютно новый четырехядерный планшет супра, картина абсолютно таже :(

Может какой-то софт стоит на всех устройствах, который конфликтует с СГ? Сброс до заводских настроек делали?

Share this post


Link to post
Share on other sites
1 час назад, nsgdima сказал:

Re:  Дайте посмотреть!)

Да запросто :) будете со мной кататься? Могу на след неделе поставить второй рег снимать работу ситигида, потому выложу ссылку на триллер ...

Re:  Может дело где-то в каких-то настройках системы?

Аппаратов несколько ... один из них абсолютно новый четырехядерный планшет супра, картина абсолютно таже :(

Могу и покататься, т.к. заинтригован) В какое время обычно Вы выезжаете с Софийской? А могу и подождать триллер)

16 минуту назад, pindos сказал:

Может какой-то софт стоит на всех устройствах, который конфликтует с СГ? Сброс до заводских настроек делали?

Не, вряд ли. Здесь где-то изюминка есть. Причем, неожиданная и банальная) Вот даже ДиОс молчит)))

Share this post


Link to post
Share on other sites
2 часа назад, /DiOs сказал:

Появление колобуха не зависит от количества пользователей. Он появляется только для регионов, для которых его появление прописано. Алматы не относится к их числу.

На обзорных масштабах маршрут цветом пробок не выделяется.

Тогда появления колобка в регионе где его появление не прописано это баг или фича? Его появление можно за скринить, он не цветной как для посетителей Васильевского острова, он просто монохромный, но он приходит из редко.

Основной вопрос был не про маршрут цветом пробок на обзорных масштабах, а про то что именно меняется при входе в обзорку и какой трафик там начинает отображается? Трафик пользователей сг3, сг5, сг7 или просто наложение окраса?

Share this post


Link to post
Share on other sites
Регистратор отдельное устройство, если и может как то влиять, то только на уровне электромагнитных помех

Re:  Версия такая:

Может конечно и так, но во первых если не перезапускать, то спутники оно не найдет никогда, ну по крайней мере за 30-40 минут не находит, во вторых с другими программами такого нет, они находят спутники нормально и двуядерность им совершенно не помеха ... Ну и насчет координат по опсосу - когда позиционирование идет по БС нет движения, а тут идет четкое движение, с правильной скоростью, только с ошибкой в 200-500 метров ...

Вашим девайсам что-то даёт огромную помеху. Ищите/убирайте провода от ВР (видеорегистратора). Теперь ещё один вопрос: какой у Вас автомобиль, т.е. лобовое стекло?

И ещё, в порядке эксперимента: не садясь в машину запустить СГ на открытой местности попробуйте.

Share this post


Link to post
Share on other sites

Вот даже ДиОс молчит)))

Угу. Вот он щас скажет "на #никсах без рута если нет фикса - надо в конфигах патчить" - и что? Легче станет?

  • Upvote 1

Share this post


Link to post
Share on other sites
15 минуту назад, leshiy333 сказал:

Вашим девайсам что-то даёт огромную помеху. Ищите/убирайте провода от ВР (видеорегистратора). Теперь ещё один вопрос: какой у Вас автомобиль, т.е. лобовое стекло?

И ещё, в порядке эксперимента: не садясь в машину запустить СГ на открытой местности попробуйте.

Дежа-вю)

3 минуты назад, IШIN сказал:

Углу. Вот он щас скажет "на #никсах без рута если нет фикса - надо в конфигах патчить" - и что? Легче станет? emoji3.png

Не, я думаю о банальности. Может, Леший прав)

Share this post


Link to post
Share on other sites

Идея проверить без машины, на лавочке - проста и гениальна. А на стекло я бы не грешил. Тут уже несколько человек писали (и я на своей приоре проверял) - стекло с подогревом не влияет (ни ВКЛ., ни выкл.)

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×