Jump to content
GPS навигатор СитиГИД
andrewrs2000

ошибка связи с сервером

Recommended Posts

Навигатор с подключением к телефону через BT, при подключении он пишет, чем в данный момент занимается :),

первое "открытие порта", затем "порт открыт", после "авторизация" вот в этот момент он так и не установив соединение снова возвращается к диалоговому окну подключения.

Я первый раз подумал, что прошел год и мне пора продлить лицензию, оказалось не требуется B).

В момент авторизации происходит подключение к серверу вашего сотового оператора для предоставления услуги GPRS, но никак не к серверу СГ. Так что в вашем случае это проблемы с ОПСОСОм.

Share this post


Link to post
Share on other sites

А какой оператор, если не секрет?

У меня тоже начались проблемы со связью начиная с 5-ой версии, в техподдержку не писал. У меня Мегафон.

Может действительно дело в операторе?

Теле2

Share this post


Link to post
Share on other sites

15 марта 2011, всю дорогу начиная с 7:50 навик пытался получить данные о пробках, так и не получил. Интернет работает на ура, а вот пробочный сервис издох :(

Кусочек лога под катом.

2011-03-15 08:12:25 --------------Start CityGuide--------------

2011-03-15 08:12:34 PGS - Connect to socket service.probki.net:1984, sended 353

2011-03-15 08:12:34 CGMS:connecting Internet:0 - ok

2011-03-15 08:12:39 CGMS:service.probki.net:1984 - ok

2011-03-15 08:12:39 CGMS:connecting socket:0 - ok

2011-03-15 08:14:41 CGMS:connected socket:10035 - failed (net error)

2011-03-15 08:14:41 PGS - Connect to socket service.probki.net:1984, errorcode 2

2011-03-15 08:14:41 CGMS:closing socket:0 - ok

2011-03-15 08:14:41 CGMS:closed socket:-1 - failed (unknown error (1))

2011-03-15 08:14:41 TAri:connecting Internet:0 - ok

2011-03-15 08:14:45 TAri:service.probki.net:1966 - ok

2011-03-15 08:14:45 TAri:connecting socket:0 - ok

2011-03-15 08:16:46 TAri:connected socket:10035 - failed (net error)

2011-03-15 08:16:46 TAri:closing socket:0 - ok

2011-03-15 08:16:46 TAri:closed socket:-1 - failed (unknown error (1))

2011-03-15 08:16:48 PGS - Connect to socket service.probki.net:1984, sended 353

2011-03-15 08:16:48 CGMS:connecting Internet:0 - ok

2011-03-15 08:16:52 CGMS:service.probki.net:1984 - ok

2011-03-15 08:16:52 CGMS:connecting socket:0 - ok

2011-03-15 08:18:54 CGMS:connected socket:10035 - failed (net error)

2011-03-15 08:18:54 PGS - Connect to socket service.probki.net:1984, errorcode 2

2011-03-15 08:18:54 CGMS:closing socket:0 - ok

2011-03-15 08:18:54 CGMS:closed socket:-1 - failed (unknown error (1))

2011-03-15 08:18:54 TAri:connecting Internet:0 - ok

2011-03-15 08:18:58 TAri:service.probki.net:1966 - ok

2011-03-15 08:18:58 TAri:connecting socket:0 - ok

2011-03-15 08:21:00 TAri:connected socket:10035 - failed (net error)

2011-03-15 08:21:00 TAri:closing socket:0 - ok

2011-03-15 08:21:00 TAri:closed socket:-1 - failed (unknown error (1))

2011-03-15 08:21:02 PGS - Connect to socket service.probki.net:1984, sended 353

2011-03-15 08:21:02 CGMS:connecting Internet:0 - ok

2011-03-15 08:21:05 CGMS:service.probki.net:1984 - ok

2011-03-15 08:21:05 CGMS:connecting socket:0 - ok

2011-03-15 08:23:07 CGMS:connected socket:10035 - failed (net error)

2011-03-15 08:23:07 PGS - Connect to socket service.probki.net:1984, errorcode 2

2011-03-15 08:23:07 CGMS:closing socket:0 - ok

2011-03-15 08:23:07 CGMS:closed socket:-1 - failed (unknown error (1))

2011-03-15 08:23:07 TAri:connecting Internet:0 - ok

2011-03-15 08:23:11 TAri:service.probki.net:1966 - ok

2011-03-15 08:23:11 TAri:connecting socket:0 - ok

2011-03-15 08:25:12 TAri:connected socket:10035 - failed (net error)

2011-03-15 08:25:12 TAri:closing socket:0 - ok

2011-03-15 08:25:12 TAri:closed socket:-1 - failed (unknown error (1))

2011-03-15 08:25:14 PGS - Connect to socket service.probki.net:1984, sended 353

2011-03-15 08:25:14 CGMS:connecting Internet:0 - ok

2011-03-15 08:25:17 CGMS:service.probki.net:1984 - ok

2011-03-15 08:25:17 CGMS:connecting socket:0 - ok

2011-03-15 08:27:19 CGMS:connected socket:10035 - failed (net error)

2011-03-15 08:27:19 PGS - Connect to socket service.probki.net:1984, errorcode 2

2011-03-15 08:27:19 CGMS:closing socket:0 - ok

2011-03-15 08:27:19 CGMS:closed socket:-1 - failed (unknown error (1))

2011-03-15 08:27:20 TAri:connecting Internet:0 - ok

2011-03-15 08:27:23 TAri:service.probki.net:1966 - ok

2011-03-15 08:27:23 TAri:connecting socket:0 - ok

2011-03-15 08:29:25 TAri:connected socket:10035 - failed (net error)

2011-03-15 08:29:25 TAri:closing socket:0 - ok

2011-03-15 08:29:25 TAri:closed socket:-1 - failed (unknown error (1))

2011-03-15 08:29:25 PGS - Connect to socket service.probki.net:1984, sended 353

2011-03-15 08:29:25 CGMS:connecting Internet:0 - ok

2011-03-15 08:29:29 CGMS:service.probki.net:1984 - ok

2011-03-15 08:29:29 CGMS:connecting socket:0 - ok

2011-03-15 08:31:30 CGMS:connected socket:10035 - failed (net error)

2011-03-15 08:31:30 PGS - Connect to socket service.probki.net:1984, errorcode 2

2011-03-15 08:31:30 CGMS:closing socket:0 - ok

2011-03-15 08:31:30 CGMS:closed socket:-1 - failed (unknown error (1))

2011-03-15 08:31:32 TAri:connecting Internet:0 - ok

2011-03-15 08:31:35 TAri:service.probki.net:1966 - ok

2011-03-15 08:31:35 TAri:connecting socket:0 - ok

2011-03-15 08:33:37 TAri:connected socket:10035 - failed (net error)

2011-03-15 08:33:37 TAri:closing socket:0 - ok

2011-03-15 08:33:37 TAri:closed socket:-1 - failed (unknown error (1))

2011-03-15 08:33:38 PGS - Connect to socket service.probki.net:1984, sended 353

2011-03-15 08:33:38 CGMS:connecting Internet:0 - ok

2011-03-15 08:33:41 CGMS:service.probki.net:1984 - ok

2011-03-15 08:33:41 CGMS:connecting socket:0 - ok

Share this post


Link to post
Share on other sites

Тоже самое: последнее время очень плохо с получением пробок. При старте получаю ДПОИ и пробки один раз (иногда пробки уже не получаю), а потом ошибка связи. В логе ошибки: 10060, 11001 (этих больше всего) и 10050

Share this post


Link to post
Share on other sites

11001 -- не получаете ответа на DNS-запрос

10050 -- просто не работает сеть

И только 10060 (таймаут) сложно интерпретировать однозначно.

Если у Вас WM, то попробуйте пойти по пути прописывания файла hosts, как недавно пробовал один из страдающих -- от 11001 во всяком случае вылечит.

Share this post


Link to post
Share on other sites

Навигатор с подключением к телефону через BT, при подключении он пишет, чем в данный момент занимается :),

первое "открытие порта", затем "порт открыт", после "авторизация" вот в этот момент он так и не установив соединение снова возвращается к диалоговому окну подключения.

Я первый раз подумал, что прошел год и мне пора продлить лицензию, оказалось не требуется B).

Аналогичная тема на WM при подключении через BT к телефону после перехода на 5 версию. Постоянно рвет соединение и переподключается через каждые 5-10 минут, потом входит в штопор и пытается коннектится покругу, соединение устанавливается и тутже рвется. На самом телефоне в это время И-нет присутствует. Через несколько часов запускаешь СГ - коннектится и все ок. Потом все повторяется.

Share this post


Link to post
Share on other sites

В продолжение: посмотрел внимательно сплошные 10060 - failed (net error). Короче проблема вырисовывается со стороны BT на устройстве под WM. Возникает после запуска СГ. Вплоть до того что: устанавливаешь и-нет соединение, все работает, данные ходят соединение не рвется. Запускаешь СГ - один раз качает пробкоданные, потом связь обрывается ... и все по кругу. Связь по BT между устройствами при этом не устанавливается.

Будет время покопаю поглубже.

Share this post


Link to post
Share on other sites

После перехода на 5.0SP1 программа каждые 3-4 мин. теряет связь и заново соединяется с сервером. В Hystory.txt постоянно встречаются строчки:

TAri:connecting Internet:0 - ok

TAri:service.probki.net:1966 - ok

TAri:connecting socket:0 - ok

TAri:connected socket:10050 - failed (net error)

TAri:closing socket:0 - ok

TAri:closed socket:-1 - failed (unknown error (1))

...

CGMS:connecting Internet:0 - ok

CGMS:service.probki.net:1984 - ok

CGMS:connecting socket:0 - ok

CGMS:connected socket:10050 - failed (net error)

PGS - Connect to socket service.probki.net:1984, err

CGMS:closing socket:0 - ok

CGMS:closed socket:-1 - failed (unknown error (1))

JamUpd:connecting Internet:0 - ok

JamUpd:service.probki.net:1960 - ok

JamUpd:connecting socket:0 - ok

JamUpd:connected socket:10050 - failed (net error)

JamUpd:OnSpJupFailure:2 - ok

JamUpd:closing socket:0 - ok

JamUpd:closed socket:-1 - failed (unknown error (1))

В связи с этим пришлось вернуться на версию 3.8

Share this post


Link to post
Share on other sites

У меня часто по утрам глючит. Особенно в понедельник.

Но все-таки я еще никак не определю кто же из тройки глючит: "Мегафон", "Тексет" или СГ.

Например, сегодня стабильно была "ошибка связи с сервером". Перегружал зверька 4 раза. При этом в интернет когда был выход, когда нет. Но когда был выход, "ошибка связи с сервером" все равно жила.

Share this post


Link to post
Share on other sites

сегодня стабильно была "ошибка связи с сервером"

Аналогично. Где-то с 07.10 до 07.40 Потом заработало

Share this post


Link to post
Share on other sites

В связи с этим пришлось вернуться на версию 3.8

Сегодня поездил с 3.8. Ситуация та же - постоянные разрывы соединения. Видимо проблема не в программе, в сервере.

Share this post


Link to post
Share on other sites

Сегодня поездил с 3.8. Ситуация та же - постоянные разрывы соединения. Видимо проблема не в программе, в сервере.

Ошибка 10050 означает простую вещь: Network is down. До каких-либо серверов в этот момент еще как до луны.

Share this post


Link to post
Share on other sites

Ситуация та же - постоянные разрывы соединения

Оператор сотовый какой?

Share this post


Link to post
Share on other sites

Кто-нибудь может подсказать, это вина девайса, программы или чего-нибудь ещё?

2011-03-21 07:06:10 JamUpd:recv:10 - ok

2011-03-21 07:07:44 JamUpd:event:0 - ok

2011-03-21 07:07:44 JamUpd:unable to save file:1 - failed (unknown error (1))

2011-03-21 07:07:44 JamUpd:OnSpJupFailure:1 - ok

2011-03-21 07:07:45 JamUpd:closing socket:0 - ok

2011-03-21 07:07:45 JamUpd:closed socket:-1 - failed (unknown error (1))

2011-03-21 07:07:50 PGS - Connect to socket service.probki.net:1984, sended 52

Share this post


Link to post
Share on other sites

Кто-нибудь может подсказать, это вина девайса, программы или чего-нибудь ещё?

Если оперировать вероятностями, то скорее всего программа на карточке, а карточка защищена от записи (сдвинули случайно предохранитель).

Share this post


Link to post
Share on other sites

всего программа на карточке,

Программа в основной памяти. На карточке только карты. И потом, оно же заработало после рестарта девайса. А сдвинуть случайно предохранитель, не вынимая карты, просто невозможно.

Т.е., всё-таки девайс?

Edited by Евгений Ш

Share this post


Link to post
Share on other sites

Т.е., всё-таки девайс?

Ну, если оперировать вероятностями :), то да.

Share this post


Link to post
Share on other sites

Подтверждаю обрывы стали чаще. Возможно совпало с 5-версией, но в 3.8 у меня их вообще не было (оператор Мегафон).

Share this post


Link to post
Share on other sites

Оператор сотовый какой?

Оператор МТС Спб.

Может это действительно совпадение, но проблема появилась при переходе на 5.0SP1.

Вообщем не знаю на что грешить - на СитиГид, МТС или на войну в Ливии...

  • Upvote 1

Share this post


Link to post
Share on other sites

да, тоже проявилось после перехода на 5.0 SP1

МТС

Edited by sergges

Share this post


Link to post
Share on other sites

Не буду утверждать, что раньше было лучше, но сейчас пару раз в день слетает. (оператор МТС)

Share this post


Link to post
Share on other sites

Хм... У меня на WM всё ок со связью...

Share this post


Link to post
Share on other sites

Вот выдернул из history:

2011-03-21 11:26:22 JamUpd:78SPb.jam:9 - ok

2011-03-21 11:26:22 JamUpd:recv:9 - ok

2011-03-21 11:26:23 JamUpd:event:0 - ok

2011-03-21 11:26:23 JamUpd:filesize:79171 - ok

2011-03-21 11:26:23 JamUpd:recv:10 - ok

2011-03-21 11:28:29 JamUpd:event:10060 - failed (net error)

2011-03-21 11:28:29 JamUpd:OnSpJupFailure:2 - ok

2011-03-21 11:28:30 JamUpd:closing socket:0 - ok

2011-03-21 11:28:30 JamUpd:closed socket:-1 - failed (unknown error (1))

2011-03-21 11:28:34 PGS - Connect to socket service.probki.net:1984, sended 105

2011-03-21 11:28:34 CGMS:connecting Internet:0 - ok

2011-03-21 11:28:45 DialUp[GPRS] - OK

2011-03-21 11:28:45 CGMS:service.probki.net:1984 - ok

2011-03-21 11:28:45 CGMS:connecting socket:0 - ok

2011-03-21 11:28:47 CGMS:connected socket:0 - ok

Что это за ошибка 10060?

Share this post


Link to post
Share on other sites

таймаут

Share this post


Link to post
Share on other sites

Я простите не силен в этих терминах, не могли бы вы пояснить, что это такое и что послужило причиной этой ошибки: устройство, оператор или СГ?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×