Jump to content
GPS навигатор СитиГИД
Joss

СитиГИД 7.7 SP для CarPC

Recommended Posts

spacer,

У меня на ноутбуке разрешение 1400х1050. Ситигид нормально запускается и работает. Что в оконном режиме, что в полноэкранном.

Share this post


Link to post
Share on other sites

Joss,

KonTur,

система Вин7 х64, вечером попробую запустить в режиме совместимости... и поставиться в виртуалке ХПмоде.

еще раз предлагаю выслать конфигурацию системы и настройки ПО для воспроизведения ситуации.

Share this post


Link to post
Share on other sites

Joss,

все оказалось на много запутаннее... дело было в кривых драйверах видеокарты ati. откатил драйвера на версию, которую предлагала поставить автоматом система и все заработало!

з.ы. драйвера 2009 года, но с ними все открывается нормально. такое чувство, что на глючных драйверах СГ запускался в оверлее...

Share this post


Link to post
Share on other sites

Та же проблема в Centrafuse 3.5-4.27 - если задать имя окна - CityGuide CARPC то кнопки перестают нажиматься. На компьютерах ASROCK Mini ITX M77 Core i3 4GB Ram 60 SSD - программа запускается в долю секуны, вообще не тормозит, но уже замечено десятком пользователей на разных машинах и с компьютерами той же конфигурацции, что местоположение отстает от 10 до 30 км от реального. Пробовали менять скорость GPS приемника - не помогает. Кто нибудь сталкивался с такой проблемой? Отставание GPS также было замечено и на версии 7.2.

Edited by Unicar

Share this post


Link to post
Share on other sites

При просмотре в разных маштабах отображается только часть ПОИ. Причем значок ПОИ может исчезать/появляться в зависимости от маштаба.

Прикладываю скриншот одномоментного состояния карты в зависимости от маштаба (включены ПОИ Аптеки). На нем видно, что Аптека Озерки (Энгельса, 111) то появляется, то исчезает в зависмости от маштаба, похоже отображаются аптеки на углу Сикейроса и Есенина. Эти места выделены на скриншоте красными и синими кругами. Наличие/отсутвие проложенного маршрута на отображение не влияет.

Что сделать, чтобы на экране одновременно высвечивались значки всех ПОИ (в зоне видимости экрана). Или это баг или может даже фича ;) ?

P.S. Похожую ситуацию заметил и на СГ под WinCE, но там скриншоты в маштабе сложнее наглядно показать.

я подправил PresRadars примерно так

<obj CodeObj="18059"> <!-- RADARS-->

<par CodeMrk="65" ColorFor="0x858585" ColorForNight="0x3F3F3F"/>

<var SclMin="0" SclMax="100000">

<elem>

<pict PictName="RADARS1.bmp"/>

<txt/>

</elem>

</var>

<var SclMin="100000" SclMax="500000">

<elem>

<pict PictName="RADARS1.bmp"/>

</elem>

</var>

</obj>

<obj CodeObj="18950"> <!-- SPCAMR-->

<par CodeMrk="65" ColorFor="0x858585" ColorForNight="0x3F3F3F"/>

<var SclMin="0" SclMax="100000">

<elem>

<pict PictName="SPCAMR1.bmp"/>

<txt/>

</elem>

</var>

<var SclMin="100000" SclMax="499000">

<elem>

<pict PictName="SPCAMR1.bmp"/>

</elem>

</var>

</obj>

<obj CodeObj="18951"> <!-- CMCNTR-->

<par CodeMrk="65" ColorFor="0x858585" ColorForNight="0x3F3F3F"/>

<var SclMin="0" SclMax="100000">

<elem>

<pict PictName="CMCNTR1.bmp"/>

<txt/>

</elem>

</var>

<var SclMin="100000" SclMax="498000">

<elem>

<pict PictName="CMCNTR1.bmp"/>

</elem>

</var>

</obj>

<obj CodeObj="18952"> <!-- CAMTRF -->

<par CodeMrk="65" ColorFor="0x858585" ColorForNight="0x3F3F3F"/>

<var SclMin="0" SclMax="100000">

<elem>

<pict PictName="CAMTRF1.bmp"/>

<txt/>

</elem>

</var>

</obj>

<obj CodeObj="18958"> <!--TRIPOD -->

<par CodeMrk="65" ColorFor="0x858585" ColorForNight="0x3F3F3F"/>

<var SclMin="0" SclMax="100000">

<elem>

<pict PictName="TRIPOD1.bmp"/>

<txt/>

</elem>

</var>

<var SclMin="100000" SclMax="496000">

<elem>

<pict PictName="TRIPOD1.bmp"/>

</elem>

</var>

</obj>

</presentation>

Edited by KonTur
длинные вещи прячем по спойлер /KonTur

Share this post


Link to post
Share on other sites

разрешение на буке 1440х900.

СГ запускается без вывода на экран. установка в res.ini разрешения 800х480 (впрочем как и 1280х800) не помогает.

Решение есть?

я создал LangPack под свое разрешение , программой LPMaker все работает

Share this post


Link to post
Share on other sites

я создал LangPack под свое разрешение , программой LPMaker все работает

дело было на в разрешении (в 7.7 не работало любое разрешение, даже в оконном режиме), а в кривых драйверах видеокарты ATi или же в том, что новая 7.7 версия СГ неправильно работает с этими драйверами.

Share this post


Link to post
Share on other sites

После установки 7.7 обнаружилось, что так и не поправлен старый глюк, описанный ещё в 7.2 релиз-кандидат

Суть сводится к следующему:

на некоторых видеокартах (в моем случае Интел945) с настройками по-умолчанию режимом 3Д пользоваться невозможно из-за проблем толи с эффектом полупрозрачности, толи с наложением одного изображения на другое... В режиме 2Д при этом всё прекрасно работает. К тому же с настройками по-умолчанию имелись проблемы с отображением указателя мыши (80% времени его не видно). Попробовал снять/поставить галку "аппаратное ускорение" - ни на что не повлияло.

Прибегнул к решению для версии 7.2 релиз-кандидат, а именно в файле settings.ini изменил значение параметра persp_mode_sights_sprite=1 на persp_mode_sights_sprite=0. Всё нормально заработало как с галкой "аппаратное ускорение", так и без неё.

Известно несколько конфигураций, на которых это проявляется:

- Интел 945GME (XPSP3)

- Samsung N145 Plus ( Intel® Graphics Media Accelerator 315) Windows 7 sp1

- нетбук samsung np-nc110-p04ru

- WinXPSp3, Nvidia 8400GS, драйвер 6.14.12.9610.

Ссылки на схожие темы:

Может быть данную "фичу" стоит описать в руководстве в разделе "Решение проблем" ?

Edited by KBAC

Share this post


Link to post
Share on other sites

Так, сегодня очередной раз проявилась проблема. Когда заходишь в "Избранное", а в нём "Подробнее" посмотреть координаты невозможно переключаться между окнами по Alt+Tab. И вообще программа перестаёт реагировать на любые действия, помогает только Ctrl+Alt+Del и снятие задачи. ОС Win8 x64, отключение аппаратного ускорения не помогает.

На днях видел вышло обновление версии под ОС Андроид, есть шанс что и данную версии вот-вот обновят?

Share this post


Link to post
Share on other sites

Отставание GPS также было замечено и на версии 7.2.

Проблема есть с GPSGate , если без него , то работает нормально. Победить пока не удалось , возможно будет работать с XPort

Работу в центрифуге удалось наладить только запустив его через плагин .

Без плагина изображение замораживается. Мало того иногда , даже если Сити Гид запущен без оболочки, при сворачивании весь экран заполняет последний кадр, ни кнопка вин на клавиатуре ни ctrl-alt-del не помогают, только alt-tab , чтобы СГ получил обратно управление и выход или повторное сворачивание .

Share this post


Link to post
Share on other sites

... невозможно переключаться между окнами по Alt+Tab. ......

у меня тоже программа виснет, при попытке свернуть ее окно . Все остальное работает. Видимо, один из нерешенных и очень неприятных глюков.

Вот еще проблемка- когда включил озвучку мужским голосом- увы, дядя чаще всего говорит лишь пол фразы ))

Если при включении GPS приемник недоступен, значит недоступен. И самый быстрый способ его подцепить- это банально перегрузить программу ( хотя, думаю, удобней было ткнуть в надпись "GPS выключен" , чтобы его подключить.

Share this post


Link to post
Share on other sites

Goga2, При сворачивании программа не виснет 100% , она просто захватывает все окно видимо ( Hwnd=0) и остальные приложения просто не могут наружу пробиться (ты их не видишь) , на ХР удается подгадывая alt-tab вернуть управление СитиГиду, после чего он реагирует на меню и можно из него выйти, тогда на экране винды сразу видны результаты работы - в слепую (запущенный таск менеджер если ctrl-alt-del жал) , запущенные программы если тыкал по экрану в район иконок.

По поводу глюков с ГПС (особенно у кого новая версия стала отставать от реальности) - как так это происходит , это загадка, но проблема появилась у 7.7 версии с GPSGate , могу только посоветовать перейти на XPort.

На данный момент имею 3 платформы, глюки на всех одинаковые. На приемниках globalstar и mediatek работает одинаково, на любой скорости. 7.7 перестал понимать com порты выше 9.

Zotac Z77-ITX i5 2500T WinXP Centrafuse 3.1 CG 7.7 запускается отдельно от СF

Zotac H67-ITX i5 WinXP Centrafuse 3.6 CG 7...

MB Intel DH77DF Xeon E3-1260L Win7 Centrafuse 3.6 CG 7...

На 2х нижних пришлось сделать возврат на 7.2 , несмотря на все вкусности, невозможно работать с 7.7. При включенном аппаратном ускорении пробки показывает красиво как в яндекс навигаторе, но не пишет скорости. Когда работает , не дает себя свернуть и не дает работать с медиаплеером (закрывает собой управление). Сбрасывает молча маршрут при переходе к другой карте. Очень часто, когда маршрут почти закончен , за 1 км делает себе харакири и убивается, при этом что 10км ехать, что 100, что 450 не важно, убивается на подъезде (видимо от радости)

Edited by dragon

Share this post


Link to post
Share on other sites

Goga2, При сворачивании программа не виснет 100% , она просто захватывает все окно видимо ( Hwnd=0) и остальные приложения просто не могут наружу пробиться (ты их не видишь) ,.....

не исключено, что дело обстоит именно так, но мне от этого не легче. Я вывел в меню СГ кнопку- "свернуть"- нажимаешь не нее и усе- экран СГ замирает, а экспериментировать в движении проблематично. А если учесть, что клавиатуру я с собой не вожу ( у меня классический кар-писи с тач-скрином), то только ресет быстро позволяет решить все проблемы. Остается только положиться на добрую волю кодеров СГ и ждать исправление глюка.

Share this post


Link to post
Share on other sites

Да почти у всех клавы нет, но .... в бардачке лежит на такие случаи гаджет

kb_mid.jpg

Edited by dragon

Share this post


Link to post
Share on other sites

А как называется сей девайс?

Отправлено с моего GT-N7000 через Tapatalk

Share this post


Link to post
Share on other sites

motyara, Знамо как - клавиатура, только маленькая, но полнофункциональная. Даже в биосе с ней можно работать

ЗЫ если тебя модель интересует, то на картинке название сайта, это чиса китайское изделие. C1541

Edited by dragon

Share this post


Link to post
Share on other sites

прочитал ветку, упоминания не нашёл.

раньше стояли winXP ситик при старте из оболочки центрифуги автоматом пытался подключиться к тырнету, то есть запускал прогу мегафон модема на старт...

сейчас переставил винду на семерку.. ситик встроил в оболочку.

при запуске ситику пофиг на отсутствие интернет соединения соответсвено модем не стартует и пробки не качаются, вручную запускаю интеренет- пробки работают..

как сделать при запуске ситика автостарт интернета?

Share this post


Link to post
Share on other sites

Таки шо у тебя новая версия 7.7 нормально в центрифуге работает?

Ты сделай автостарт интернета при запуске компа. в настройках программы от МелаФона поставь галки

1 запуск одновременно с ОС

2 Соединяться при запуске и автонабор номера при обрыве коннекта

ЗЫ А по СитиГиду - хотелось бы, чтобы он без бубнов работал в центрифуге

Share this post


Link to post
Share on other sites

как сделать при запуске ситика автостарт интернета?

Перый вопрос.

Share this post


Link to post
Share on other sites

А по СитиГиду - хотелось бы, чтобы он без бубнов работал в центрифуге

А вы эту тему с самого начала читали?

Share this post


Link to post
Share on other sites

KonTur, Про кнопку громкости? Или что все хотят ездить без бубнов?

Не проканывает.

Только с плагином старым и-то через раз при назначении маршрута "виснет экран", только голос остается. Всё уже перепробовано. Пока оставил одну машину с СГ 7.7 , пускаю без центрифуги

Share this post


Link to post
Share on other sites

dragon,

Тогда сочувствую. Значит мне повезло.

Share this post


Link to post
Share on other sites

Слушайте, а можно как нить бороться с масштабированием карты колесиком мыши? Очень уж чуствительный масштаб какой-то. Каждый шелчек колесика отрабатывает. А шаг масштаба крупный. Крутанул колесико на 5 щесчков и СГ собрал Москву в точку )) Жутко неудобно масштабировать при такой чуствительности. Может шаг масштаба где задается у СГ. Раньше вроде не замечал, а на последней 7.7 версии прям кашмар какой-то ((

Запускаю на ноуте. Винда 7, 32 бит.

Share this post


Link to post
Share on other sites

Nahalleon,

Это настраивается не в Ситигиде, а в самой мыше. Панель управления - Мышь - Ролик. Может у вас там стоит страницу прокручивать за один щелчок ролика. Или 3 строки (как по умолчанию).

Share this post


Link to post
Share on other sites

KonTur,

Я туда даже не собирался лазить. Мне это за ненадобностью. Меня вполне и настройки по умолчанию ролика устраивают, т.е. те самые 3 строки.

И ролик тут не причем. Это что-то в 7.7 подкрутили. Потому как на 7.2 не так круто было с масштабированием. Либо это эз-за того что карты для 7.7 новые. Я уж не знаю почему, но что есть, то есть. Масштаб чуствительный.

Ради успокоения души, сменил настройки ролика на 1, вместо 3. Картина в СГ, какя и ожидал не меняется от этого ни на грамм. Как был шаг масштаба, так и остался. Так что это СГ рулит масштабом и регулировать нужно в нем.

Edited by Nahalleon

Share this post


Link to post
Share on other sites
Вы решили ответить в очень древней теме. Возможно, Вам стоит создать новую тему.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...