Jump to content
GPS навигатор СитиГИД
Sign in to follow this  
3anpocmo

Проблема с загрузкой программы

Recommended Posts

Сегодня днём CG работал как всегда отменно, но вечером достигнув 95% загрузки на 10 сек. задумывался, после чего программа вылетает. Пробовал много раз, в т.ч с перезагрузкой аппарата, но результат такой же. Я даже переустановил снова 5 версию, но ничего не выходит.

Помогите!

Share this post


Link to post
Share on other sites

переформатировать флешки, перепрошить девайс?

Share this post


Link to post
Share on other sites

переформатировать флешки, перепрошить девайс?

Две недели назад уже делал из-за иной проблемы. С тех пор всё работало нормально! Да и сейчас все проги работают. Скажем Навител без проблем, но он мне не нравится!

Share this post


Link to post
Share on other sites

стал откатывать программу назад. заработала верситя 3.5

почему же пятёрка не работает?

Share this post


Link to post
Share on other sites

А с памятью/дисковым пространством все нормально?

Возникла шальная мысль - может, при попытке индексировать карту (т.е.распаковать из нее чего-то там) или распаковать из лангпака временные файлы программа упирается в нехватку мозгов/места?

Share this post


Link to post
Share on other sites

А с памятью/дисковым пространством все нормально?

Возникла шальная мысль - может, при попытке индексировать карту (т.е.распаковать из нее чего-то там) или распаковать из лангпака временные файлы программа упирается в нехватку мозгов/места?

Да нет, памяти полно. И ведь он до вчерашнего дня нормально работал и только вечером, вдруг, началась такая котовасия.

Все файлы и прога лежат на карте. Там свободного места 1,8 Гб.

Edited by 3anpocmo

Share this post


Link to post
Share on other sites

Да нет, памяти полно. И ведь он до вчерашнего дня нормально работал и только вечером, вдруг, началась такая котовасия.

Все файлы и прога лежат на карте. Там свободного места 1,8 Гб.

1. Удалить программу.

2. Почистить реестр.

3. Установить программу.

Будет работать.

  • Upvote 1

Share this post


Link to post
Share on other sites

Почистить реестр.

Какой реестр Вы имеете ввиду? Удалить всю папку с установочными файлами в Программных файлах?

Share this post


Link to post
Share on other sites

ребята help у меня устройтво phantom dvm windows ce и ситигд 5.1 такая проблема с запуском постоянно когда запускаеш первый раз садясь в машину не запускается навигация ,пишет aplication error и т д mostscript.exe приходится все время рестарт нави делать после чего работает все ок, не подскажите в чём проблема?

Share this post


Link to post
Share on other sites

Какой реестр Вы имеете ввиду? Удалить всю папку с установочными файлами в Программных файлах?

Не дай Бог! :)

У WM есть реестр, в него надо зайти и удалить там папку MIT.

Если Вы в СПБ - вэлком в личку.

Share this post


Link to post
Share on other sites

Поддержу данную тему.

У меня все точно как описано в посте случалось уже 4 раза. Каждый раз лечится только полным удалением ветки в реестре и удалением программы. Оставляю только все что касается карт в отдельной папке и пару файлов типа закладок и лицензии (чтобы не вводить каждый раз номерки 2 раза, а всего лишь 1 раз ))

Так вот собственно вопрос. Не пора ли все таки найти решение данной проблемы поинтереснее чем снос всего что движется? Может кто-то доковырялся до проблемы и есть волшебный ключик ?

Проблемы начались с программы версии 5. Я уже пробовал менять сборку системы и прошивку, но все таки похоже косяк в аппарате или в самой программе. Давно сижу на СитиГиде и всяких конкурентов приемлю только за границей, но когда в самый нужный момент оказываешься без помошника (за 5 сек перегрузка всего не получается) начинаешь мыслить не очень цензурными выражениями...

Share this post


Link to post
Share on other sites

Вообще-то считается, что данная проблема может проявиться один раз при переходе с 3.8 и больше ни-ни.

Если у Вас постоянно слетает - где-то что-то нужно копать.

Share this post


Link to post
Share on other sites

3anpocmo

Сколько свободно оперативной памяти? Для запуска Сити Гид необходимо от 20-30 мб свободной оперативки

Edited by ddss

Share this post


Link to post
Share on other sites

Памяти постоянно свободной около 26 Мб.(всего у девайса только 64 есть) После появления этой ошибки программу больше вообще не запустить ни при каких условиях. Если бы дело было в памяти, то она бы решалась после банальной перезагрузки или освобождения памяти принудительно. Самое плохое, что не могу понять после какого действия в рабочей программе я делаю ее незапускаемой в следующий раз. Может там надо маршрут убить или пробки отключить/включить...

Share this post


Link to post
Share on other sites

Прогу снёс. Реестр почитил. Заново установил: всё заработало!

НО ЕСЛИ ЭТО ПРОЯВИТСЯ ВНОВЬ? ЧТО ДЕЛАТЬ? КАК ВИДНО ВЫШЕ Я ТАКОЙ НЕ ОДИНОК

Share this post


Link to post
Share on other sites

Поставь себе программу spb backup и делай регулярно бэкапы системы. А когда что либо случится, то ты всегда сможешь воспользоваться файлом который эта программа создала и откатишься на тот момент когда ты сделал себе последний бэкап. Мест где ее скачать с ключиком навалом.

Это решит твою проблему, у меня когда с комуником начинаются вского рода глюки то я пользуюсь этой прогой и все решается

Share this post


Link to post
Share on other sites

НО ЕСЛИ ЭТО ПРОЯВИТСЯ ВНОВЬ? ЧТО ДЕЛАТЬ? КАК ВИДНО ВЫШЕ Я ТАКОЙ НЕ ОДИНОК

Пожалуй, повторю: как правило эта ошибка проявляется только один раз, при переходе с 3.х на 5.0 (мне ещё неизвестно ни одного случая рецидива).

Share this post


Link to post
Share on other sites

Ответ для тех кому это актуально.

У меня проблема описанная в шапке случается периодически (а не только один раз). Связано я думаю с нехваткой памяти из-за утечки или еще чего-либо. Но решения я нашел. После первой установки и настройки скопировал файлик DictPOI в отдельную папочку. И теперь, как только прога вылетает при загрузке на процентах от 95 до 99, я сразу тупо лезу в проводник и переписываю этот сохраненный файл поверх того что портит мне всю малину. Помогает - это проверено!

  • Upvote 1

Share this post


Link to post
Share on other sites

У меня на днях тоже перестала запускаться. Только не на 95 процентах, а вообще. На пару секунд появляются "часики" WinMobile - и тишина. Причина непонятна - никаких существенных действий на КПК не производил, типа установки программ.

Замена DictPOI не помогла, пришлось переустанавливать. Но несколько странным образом. Вначале поставил (поверх, по ошибке) 3.5SP1, а потом (раз уж пошла такая пьянка) - современную версию, тоже ничего не удаляя. В результате всё работает, закладки-настройки сохранились. Потратил менее 10 минут.

Share this post


Link to post
Share on other sites

У меня такое было только на WM5.0 (FS n560). На WM6.1 все нормально.

Share this post


Link to post
Share on other sites

Уже второй раз за последний месяц такая проблема, только у меня загружается до 90% и вылет... Звонил в саппорт - сказали что возможно повреждение файла карты, типа скачайте и перекиньте карту заново. Помогло. Но что теперь. каждую неделю карту заново сливать на навигатор?

Share this post


Link to post
Share on other sites

Но что теперь. каждую неделю карту заново сливать на навигатор?

А Вы как из программы выходите? Через штатный выход или выключением навигатора? И где лежат карты -- в устройстве или на карте?

Share this post


Link to post
Share on other sites

@/DiOs

Из программы выхожу через кнопку Выход, карты памяти нет, поэтому все карты в самом устройстве.

А вообще, описанная теория сейчас несработала, хз почему. =((((

Share this post


Link to post
Share on other sites

У меня такое случалось регулярно, а также бывали случаи, когда прога вроде бы стартует нормально,

а пробки получать не хочет (у меня пда-шник коннектится с телефоном через блютус, так соединение

по блютусу вообще не устанавливается). Взял за правило: перед запуском СГ делать ресет пда-шника

(не пугайтесь, горячий - чтобы очистить память) и проблема решилась на 100%. Цена вопроса - всего секунд 30 на ресет.

Share this post


Link to post
Share on other sites

...только у меня загружается до 90% и вылет...

Приключилось то же самое.

При ОСС, связь не смогла восстановиться в течении получаса. В сердцах был произведен RESET прямо из программы.

Интернет-связь восстановилась, а СГ на 95%, после надписи "индексация" - вылетает. И, ни в какую!

СГ 5.0 переставил - не помогло. 98 -ю удалил везде, СГ загрузился без карт, но при загрузке Евразии, 47-ой и 78-ой, программа

опять вылетела с серым окном и звонким пуком. И опять - девяносто пять :wacko:

Посоветуйте, плиз, кто силен: какого болта?

Edited by Gonza

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×