Jump to content
GPS навигатор СитиГИД
KonTur

CarPC 5.1 для компьютеров с поддержкой touchscreen.

Recommended Posts

Неужели проблемы с отображением собственных POI есть только у меня?

Версия 5.1 langpak стандартный.

POI у меня отображаются только в следущем случае

Создаю файлик 77Mos.radar.txt в папке с картами (вместо radar пробовал все что угодно). Первая строка выглядит так:

1|> Камеры Гибдд|1251|CityPlan01:24|65|1001

Загружаю карту Москвы, создается файл 77Mos.upoi. Если нужно поменять POI, приходится удалять файл.

В меню Карта->Показ POI появился пункт "Дорожные знаки", в нем "Радары", сами обьекты отображаются значками Radars1.bmp из langpak'a

Теперь о проблеме.

Изменяя номер глифа 65 ничего не меняется.

Загадочное число 1001. Насколько я понял программа его воспринимает, как глиф, если его нет, обьекты не отображаются, но их можно найти через поиск-прочие обьекты-отобразить все. Пробовал подбирать другие числа, не получилось

Не отображать же все свои POI значками радаров!

Кто чего подскажет?

Share this post


Link to post
Share on other sites

Кто чего подскажет?

Попробуйте создать файл POI.bkm и положить вместе с картами.

Формат:

2|GeneralPOI|65001

18000|название|57.312571|42.941576|

или

2|GeneralPOI|1251

18000|название|57.312571|42.941576|

Share this post


Link to post
Share on other sites

Уж было хотел сказать, что не сработало, но при большом приближении (масштаб 17000) появился квадратик с галкой и подписью. Но в меню "показ POI" ни через поиск не удалось найти

Share this post


Link to post
Share on other sites

Описанный выше пример, обьект отображается вместе с прочими-остальными обьектами, и параметры генерализации совсем не устраивают. В Москве отобразился только при масштабе 1:7000

А вот такой пример уже вовсе не работает

2|Speed limit 60|1251

18911|название|55.632633|37.703586|

Share this post


Link to post
Share on other sites

А вот такой пример уже вовсе не работает

2|Speed limit 60|1251

18911|название|55.632633|37.703586|

В данном случае файл - TraffSign.bkm и заголовок 2|TrafficSign|1251

Share this post


Link to post
Share on other sites

Огромное спасибо, работает!

Share this post


Link to post
Share on other sites

Народ, такая вот проблема. Юзал 3ю версию ситигида, всё было отлично. Качнул 5ю. Настройки гпс сделал такие же как в 3м, т.е. скорость порта 38400 и 17 ком порт под gps. Запускаю-не видит гпс, пишет, что нет сигнала или вообще ничего не пишет. Но при этом порт гпс занят, т.е. при запущенном 5м ситигиде, 3й ругается, что нет доступа к гпс, выхожду и 5-го, 3й начинает норм работать.

Где у меня кривые руки? В настройках больше ничего не настраивал, кроме порта гпс и скорости. Скачал все карты через программу. Всё.

Share this post


Link to post
Share on other sites

Во, вроде понял, в чём косяк. Прога то видит gps,то нет, часто отваливается связь. Обновление карты происходит раз в 5-7 сек, в 3й же версии обновление было непрерывно. Что-то можно поправить в настройках? Или это кривые руки разрабов?

Share this post


Link to post
Share on other sites

MishganSP,

У вас как я понял блютус ГПС приемник?

Может попробовать COM порт переназначить на что-нибудь меньше 8 ?

И скорость на 4800 попробовать.

Share this post


Link to post
Share on other sites

usb приемник. скорость менял- не помогает

Share this post


Link to post
Share on other sites

поменял скорость порта-вообще гпс потерялся и больше не работал не при каких скоростях

Share this post


Link to post
Share on other sites

А вы меняли в настройках винды? или только в СитиГиде?

Share this post


Link to post
Share on other sites

А вы меняли в настройках винды? или только в СитиГиде?

В ситигиде. Ко мне можно на ты, чай не господин :)

Share this post


Link to post
Share on other sites

Ну так СитиГид спрашивает у системы ГПС приемник на том порту что у него в настройках. А в системе приемник может быть совсем на другом порту.

Автопоиск ГПС приемника в СГ делал?

Я бы конечно сначала в Диспетчере устройств поменял порт приемника на меньший, лучше менее 8-го, а потом в СГ сделал автопоиск -

Меню-Настройки-Основные-COM порт поставить "Авто". Убедится что стоит галка на "Включать ГПС при старте". Выйти из СГ и запустить его вновь.

Share this post


Link to post
Share on other sites

Ну так СитиГид спрашивает у системы ГПС приемник на том порту что у него в настройках. А в системе приемник может быть совсем на другом порту.

Автопоиск ГПС приемника в СГ делал?

Я бы конечно сначала в Диспетчере устройств поменял порт приемника на меньший, лучше менее 8-го, а потом в СГ сделал автопоиск -

Меню-Настройки-Основные-COM порт поставить "Авто". Убедится что стоит галка на "Включать ГПС при старте". Выйти из СГ и запустить его вновь.

Я ж говорю, в системе он на 17м порту, это 100%.(глядел с диспетчере устройств, к тому же на 17м порту, хоть и оч криво, но работало всё) И с этими настройками (17й порт и скорость 38400) 3й ситигид пашет на ура. Стоит-"включать гпс при старте". Была галка-переподключаться при потере сигнала, но я её убрал. От неё ничего не зависит, как я понял.

Share this post


Link to post
Share on other sites

3-ка и 5-ка - несколько разные вещи. И если тройка работала с 17 портом, то это никак не значит, что и 5-ка также с ним работает. Я думаю что порты больше 8 никто не тестировал.

Я бы все-таки в системе попробовал ГПС приемник повесить на порт меньше 8.

Share this post


Link to post
Share on other sites

3-ка и 5-ка - несколько разные вещи. И если тройка работала с 17 портом, то это никак не значит, что и 5-ка также с ним работает. Я думаю что порты больше 8 никто не тестировал.

Я бы все-таки в системе попробовал ГПС приемник повесить на порт меньше 8.

cтранно ,како отношение имеет НОМЕР порта к скорости работы проги.

Ну надо, значит надо, завтра попробую перевесить гпс.

Share this post


Link to post
Share on other sites

Повесил гпс на ком 2. Третий как всегда работает, пятый тупит жутко

Share this post


Link to post
Share on other sites

Ну тогда не знаю. Остается ждать следующей версии, может она будет нормально работать на твоей конфигурации.

Share this post


Link to post
Share on other sites

Порты в 5.1 версии выше 8 работают, точно говорю - у меня сейчас напрямую, без гейтов и х-портов gps модуль на 31 висит, все отлично работает.

MishganSP, у тебя, случаем, gps модуль не Скайтрэк ?

Share this post


Link to post
Share on other sites

Название не помню. Мб и скайтрек, а что?

Share this post


Link to post
Share on other sites

обновление картинки в проге происходит в среднем через 5-20 сек. Что за фигня?

Share this post


Link to post
Share on other sites

Название не помню. Мб и скайтрек, а что?

Посмотрите, пожалуйста. Если да, то будете третьим в нашей компании несчастных обладателей сего приемника и страдающих от тормозов :(

Share this post


Link to post
Share on other sites

Здравствуйте! Года два пользовался СитиГидом на WinCE и вот решил таки внедрить в машину КарПиСец :-)))). На обоих девайсах стоят версии "5". На обоих девайсах задействованы последние карты "Санкт-Петербург и обл." При поиске по адресу, в навигаторе сверху окна поиска написано "Санкт-Петербург и обл." и он осуществляет сквозной поиск улицы по всем населённым пунктам Ленобласти. При тех же настройках КарПиСюк ищет только в конкретном населённом пункте, название которого выведено сверху окна. Т.е. мотаясь по городу и области мне приходится каждый раз вводить населённый пункт. Не смертельно, но раздражает. Может где кувалдой подстучать или оно так и должно быть?

Share this post


Link to post
Share on other sites

SeaDog,

Меню-Поиск-Еще-Выбирать карту при поиске

Никаких других вариантов мне в голову не приходит...

  • Upvote 1

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×