Jump to content
GPS навигатор СитиГИД

Не могу внести изменения в settings.ini


Go to solution Solved by dimalish,

Recommended Posts

Ради интересу попытался включить индикатор оставшейся памяти.

Открыл settings.ini, там уже есть строчка с Memory...InMb = 0

Изменил на 60. Сохранил.

Запускаю СитиГид, а он как не родной требует ввести лицензию, заригистрироваться через интернет... все как в первый раз прям.

Ввел, зарегистрировался... все настроил. Остаток памяти не показывается.

Думаю, ладно, наверно это на Маке у меня чего-то с перевом строк не так редактор прописал, СитиГид своего файла не узнал.

Попробовал отредактировать settins.ini прямо на WinCE в TotalCommander.

Тот settings.ini вообще криво показывает, не разбивает на строки.

Ну все равно нашел нужный параметр, вписал туда уже 100 на всякий случай.

Запускаю СитиГид — опять как в первый раз. Все настройки слетели, индикатора памяти нет.

Вышел из СГ, опять полез в settings.ini — а там 0мб вместо моих 100.

 

 

Что я делаю не так? Какие-то тонкости есть?

 

пс. В девайсе 120мб без копеек.

Link to post
Share on other sites

Ради интересу попытался включить индикатор оставшейся памяти.

Открыл settings.ini, там уже есть строчка с Memory...InMb = 0

Изменил на 60. Сохранил.

Запускаю СитиГид, а он как не родной требует ввести лицензию, заригистрироваться через интернет... все как в первый раз прям.

Ввел, зарегистрировался... все настроил. Остаток памяти не показывается.

Думаю, ладно, наверно это на Маке у меня чего-то с перевом строк не так редактор прописал, СитиГид своего файла не узнал.

Попробовал отредактировать settins.ini прямо на WinCE в TotalCommander.

Тот settings.ini вообще криво показывает, не разбивает на строки.

Ну все равно нашел нужный параметр, вписал туда уже 100 на всякий случай.

Запускаю СитиГид — опять как в первый раз. Все настройки слетели, индикатора памяти нет.

Вышел из СГ, опять полез в settings.ini — а там 0мб вместо моих 100.

Что я делаю не так? Какие-то тонкости есть?

пс. В девайсе 120мб без копеек.

Почему-то принято забивать всего 16. Я на все девайсы WinCE этот параметр менял обычным блокнотом.

Отправлено с ПИШУЩЕЙ МАШИНКИ через ТЕЛЕГРАФ ;)

Link to post
Share on other sites

Надо обратить внимание на кодировку страницы - если не ошибаюсь она в какомто UT, а блокнот может отредактировать и сохранить в 1251 - есно СГ не прочитает - следствие запросит активацию и создаст новый setting.ini :)

  • Upvote 1
Link to post
Share on other sites
  • Solution

Да, ноутпадом под WinXP все сохранилось и заработало.

Оказывается, settings.ini в кодировке utf-16. А поскольку русских симоволов там больно-то и нет, он открывается с виду нормально как win-1251. Но после сохранения оказывается нечитабельным для СитиГида.

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
×
×
  • Create New...