Jump to content
GPS навигатор СитиГИД
Sign in to follow this  
Dormidond

Китайское ГУ и 10.2.128

Recommended Posts

Доброго дня.

Проблема: ГУ в машине на Андроид 8, перепробовано: Сити Гид, В гео, Гео нет.

У всех одно и то же: во время движения (более 15 км/ч)  программа начинает постоянно перезагружаться.

Остальные навигаторы работают корректно...

Подскажете, что у меня не так?

Share this post


Link to post
Share on other sites
Доброго дня.
Проблема: ГУ в машине на Андроид 8, перепробовано: Сити Гид, В гео, Гео нет.
У всех одно и то же: во время движения (более 15 км/ч)  программа начинает постоянно перезагружаться.
Остальные навигаторы работают корректно...
Подскажете, что у меня не так?
3D, дома включены? настройки нужно смотреть

Google Pixel 2XL 128Gb через Tapatalk

Share this post


Link to post
Share on other sites

Пробовал во всех режимах. На телефоне работает, на ГУ - нет.

Share this post


Link to post
Share on other sites
3 часа назад, Dormidond сказал:

У всех одно и то же: во время движения (более 15 км/ч)  программа начинает постоянно перезагружаться.

Вариант 1 - не ездить быстрее 15 км/ч;)

Вариант 2. Хрен знает, что там у вас с магнитолой, но... Вероятно, что в районе 15 км/ч на экране что-то меняется - или наклон, или масштаб. Чтобы локализовать проблему нужно попробовать зафиксировать наклон карты и масштаб и проверить.

И да, неплохо сообщить параметры магнитолы - версию андроида, сколько там оперативки...

Share this post


Link to post
Share on other sites

Андроид 8, 4 гб оперативки, 64 вн память - за глаза.

Как зафиксировать наклон и масштаб?

Share this post


Link to post
Share on other sites
3 минуты назад, Dormidond сказал:

Как зафиксировать наклон и масштаб?

Наклон где-то в настройках, а масштаб... Ковыряться надо. Мож кто подскажет?

З.Ы. Это только моя гипотеза навскидку

Share this post


Link to post
Share on other sites
Posted (edited)
7 минут назад, Dormidond сказал:

Как зафиксировать наклон и масштаб?

Меню-карты-Настройки-Автомасштаб.

Выбрать "Нет, 2D".

 

Даже у самого убогонького телефона и мозгов, и хранилища должно хватать.

Это ж не ВинСЕ все-таки.

Так что (учитывая, что Вы уже локализовали один из параметров, который коррелирует с вылетами - скорость), подозреваю, что @svlad2012  возможно прав, и проблема где-то в реализации работы с аппаратным ускорением (оно же ОпенГЛ).

Возможно, именно с Вашим графическим ускорителем СГ некорректно работает.

И например, это происходит тогда, когда он пытается наклонить карту...

А еще можно посмотреть в папке LOG

(у меня это во внутр.памяти Android\data\cityguide.probki.net\files\log)

файл errors.txt - вдруг в нем осталась запись - в какой момент оно рухнуло...

Edited by IШIN
  • Like 1

Share this post


Link to post
Share on other sites
Наклон где-то в настройках, а масштаб... Ковыряться надо. Мож кто подскажет?
З.Ы. Это только моя гипотеза навскидку
Мне тоже наклон не нравится в Автомасштабе. Приходится мириться как и с испортившиеся прокладкой маршрута... (

Google Pixel 2XL 128Gb через Tapatalk

Share this post


Link to post
Share on other sites

Спасибо. проверю еще это, отпишусь....

Share this post


Link to post
Share on other sites

В логе - куча текста, - что искать?

Share this post


Link to post
Share on other sites

Нууу, по идее искать ошибки по времени - когда вылет был.

Или можно удалить файл, потом запустить СГ и попробовать довести до вылета. А потом анализировать файл, т.к. в нем ПО ИДЕЕ почти не будет хлама.

Share this post


Link to post
Share on other sites

При запуске программы надпись:
"Developer warning for package «net.probki.bgeo»
Failed to post notification on channel «null»
See log for more details"
Перевод : Предупреждение разработчика для пакета " net.пробки.bgeo»
Не удалось разместить уведомление на канале " null»
Дополнительные сведения см. В разделе log
Что делать?

Share this post


Link to post
Share on other sites
13 часов назад, Dormidond сказал:

Что делать?

"See log for more details";)

Дык, показали бы, что там в лог-файле

Share this post


Link to post
Share on other sites

Сначала я переустановил навигатор.

Наверное, первая часть лога - это инфо по установке, потом идет информация в движении, когда экран все время перезагружается:

image.thumb.png.da533bc6085cbabc75bb253d6d46aba9.pngCannot find </storage/emulated/0/Android/data/net.probki.geonet/files/settings.ini> <rb>

Settings ReadFile /storage/emulated/0/Android/data/net.probki.geonet/files/settings.ini error=1

Settings Init error

Cannot find </storage/emulated/0/Android/data/net.probki.geonet/files/settings.ini> <rb>

Settings ReadFile /storage/emulated/0/Android/data/net.probki.geonet/files/settings.ini error=1

Settings Init error

Cannot find </storage/emulated/0/Android/data/net.probki.geonet/files/settings.ini> <rb>

Settings ReadFile /storage/emulated/0/Android/data/net.probki.geonet/files/settings.ini error=1

Settings Init error

USE_HTTP_QUEUE_SUBSYSTEM

Cannot find </storage/emulated/0/Android/data/net.probki.geonet/files/settings.ini> <rb>

Settings ReadFile /storage/emulated/0/Android/data/net.probki.geonet/files/settings.ini error=1

Settings Init error

Cannot find </storage/emulated/0/Android/data/net.probki.geonet/files/settings.ini> <rb>

Settings ReadFile /storage/emulated/0/Android/data/net.probki.geonet/files/settings.ini error=1

Settings Init error

Cannot find </storage/emulated/0/Android/data/net.probki.geonet/files/settings.ini> <rb>

Settings ReadFile /storage/emulated/0/Android/data/net.probki.geonet/files/settings.ini error=1

Settings Init error

sounds '/storage/emulated/0/Android/data/net.probki.geonet/files/en_female.cgsnd' deployed, 1

sounds '/storage/emulated/0/Android/data/net.probki.geonet/files/ru_female.cgsnd' deployed, 1

RSS DB: can not prepare statement: DROP TABLE[RssFeeds];. Result: 1

execute sql failed: DROP TABLE[RssFeeds];, error -1

RSS DB: can not prepare statement: DROP TABLE[RssItems];. Result: 1

execute sql failed: DROP TABLE[RssItems];, error -1

ptt: saved new /storage/emulated/0/Android/data/net.probki.geonet/files/Scripts/Podcasts.bkm, 14:18

LangPack ERROR: unable to find menu "InfoPanel"

juxi:proc FN 528 tick(s) (at 117398863)

USE_HTTP_QUEUE_SUBSYSTEM

juxi:proc FN 513 tick(s) (at 117590768)

USE_HTTP_QUEUE_SUBSYSTEM

podcast catalog file receive failed

podcast catalog file receive failed

podcast catalog file receive failed

podcast catalog file receive failed

juxi:proc FN 520 tick(s) (at 119389717)

juxi:proc FN 513 tick(s) (at 119394782)

podcast catalog file receive failed

juxi:proc FN 502 tick(s) (at 119412278)

podcast catalog file receive failed

podcast catalog file receive failed

juxi:proc FN 510 tick(s) (at 119450575)

podcast catalog file receive failed

juxi:proc FN 508 tick(s) (at 119487006)

podcast catalog file receive failed

juxi:proc FN 500 tick(s) (at 119501816)

juxi:proc FN 528 tick(s) (at 119506151)

podcast catalog file receive failed

juxi:proc FN 502 tick(s) (at 119525183)

podcast catalog file receive failed

juxi:proc FN 519 tick(s) (at 119530112)

juxi:proc FN 544 tick(s) (at 119536360)

podcast catalog file receive failed

juxi:proc FN 505 tick(s) (at 119554985)

podcast catalog file receive failed

juxi:proc FN 524 tick(s) (at 119587278)

podcast catalog file receive failed

juxi:proc FN 545 tick(s) (at 119591732)

podcast catalog file receive failed

juxi:proc FN 548 tick(s) (at 119625425)

podcast catalog file receive failed

juxi:proc FN 502 tick(s) (at 119646159)

podcast catalog file receive failed

podcast catalog file receive failed

Share this post


Link to post
Share on other sites

Подождем, что скажут профессионалы. 

Но что интересно - все ошибки так или иначе связаны вроде с подкастами, RSS и др онлайн шелупонью, не только не нужной, но и вредной.

А если попробовать отключить всю хрень в настройках?

В меню Онлайн я попробовал бы поснимать галки у Достопримечательностей (отображать на карте), и в RSS ленты - Настройки RSS - снять все галки

Share this post


Link to post
Share on other sites

А почему речь идет о 128й сборке? 141ю (или 142ю бету) не пробовали?

Share this post


Link to post
Share on other sites

Меня больше смущают вот эти ошибки:

4 часа назад, Dormidond сказал:

Cannot find </storage/emulated/0/Android/data/net.probki.geonet/files/settings.ini> <rb>
Settings ReadFile /storage/emulated/0/Android/data/net.probki.geonet/files/settings.ini error=1
Settings Init error

LangPack ERROR: unable to find menu "InfoPanel"

 

 

Share this post


Link to post
Share on other sites

Я тоже заметил. Подумал, что может, при первом запуске он не находит настроек, и в итоге создает ini заново из default.ini?

Про podcast file error и у меня есть (никаких вылетов, возможно на определенных аппаратах влияет. А возможно подкасты и ни при чем)

А про InfoPanel - тоже и у меня есть.

Думаю, косяк в лангпаке. Где-то сделана ссылка на раскладку InfoPanel, а в лэйаутах ее нет. но это уж не должно быть причиной вылетов. 

Share this post


Link to post
Share on other sites
18 минут назад, KonTur сказал:

Меня больше смущают вот эти ошибки:

 

В моём логе такая хрень тоже присутствует. Тем не менее всё работало, не вылетало . 

Единственное, что у меня по-другому: похоже после ввода лицензии в этом файле перед строками USE_HTTP_QUEUE_SUBSYSTEM (и не только) теперь строка с каким-то кодом (четыре группы символов по четыре символа через тире). А так тоже периодически есть строки "podcast catalog file receive failed" и "LangPack ERROR: unable to find menu "InfoPanel"" и ничего - вроде всё работает.

Работает... если не считать того, что иногда при старте линия маршрута рисуется не стрелочками, а телефонами (писал об этом в теме релиза). Потом при смене наклона карты (или масштаба?) всё становится нормальным (т.е. при скорости около 15 км за час, как у автора вопроса?).

Share this post


Link to post
Share on other sites
7 минут назад, svlad2012 сказал:

теперь строка с каким-то кодом (четыре группы символов по четыре символа через тире)

Разве не серийник? (сам цифры не сравнивал)

 

Share this post


Link to post
Share on other sites
5 минут назад, IШIN сказал:

Разве не серийник? (сам цифры не сравнивал)

 

Не-а. По структуре похож на номер лицензии, но не оно

Share this post


Link to post
Share on other sites
11 минут назад, svlad2012 сказал:

По структуре похож на номер лицензии, но не оно

Тады может DeviceID, которым раньше в ЛК активировали лицензию...

Share this post


Link to post
Share on other sites

У меня и на телефоне и на планшете таких ошибок в логах нет. Раньше, да появлялись. Все-таки повторю вопрос - о каком билде Ситигида идет речь?

Share this post


Link to post
Share on other sites
12 минут назад, Fanat_SPB сказал:

У меня и на телефоне и на планшете таких ошибок в логах нет

Возможно, у тебя скин от Фотолома, и возможно, он этот косяк вырезал, не дожидаясь перитонитов.

Share this post


Link to post
Share on other sites
Posted (edited)
3 минуты назад, IШIN сказал:

Возможно, у тебя скин от Фотолома,

У меня сток, 142я бета (не знаю менялся ли лэнгпак 141->142).

Edited by Fanat_SPB

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×