Jump to content
GPS навигатор СитиГИД
Sign in to follow this  
orlov83

Вопрос по меню

Recommended Posts

При долгом нажатии на месте на карте появляется меню Финиш Заехать Откл.GPS и прочее... Меню закрывает важные сведения и висит, пока его не отрубишь как-нибудь. Нашел пару способов отключения - Скопировать координаты нажать, затем кнопку назад или Точку и кнопку Назад. 

Суть проблемы - едешь, хочешь посмотреть дорогу впереди, немного полистал, нажал кнопку возвращения к маршруту и едешь дальше - в какой-то момент можно слегка промазать по кнопке возврата к маршруту или чуть дольше задержаться на точке пальцем - возникает это чертово меню, которое закрывает важную информацию - куда через сколько поворачивать и часть карты вверху - т.е. благодаря ему не видно куда ехать так-то. И на ходу целенаправленно тыкать по кнопкам его убирать очень неудобно. Кнопок много - но отмены данного меню ни одной простой кнопки я не увидел. Можно как-то настроить, что бы оно хотя бы горело секунд 5 и пропадало или вывести кнопку отключения?

  • Like 1

Share this post


Link to post
Share on other sites

Угу. По идее еще раз тапаешь по экрану и это меню исчезает.

А практически можно долбить по экрану, как дятел - нифига не помогает, только через "скопировать координаты", а потом тап мимо меню "куда копировать"

Share this post


Link to post
Share on other sites

А у меня такой проблемы нет... И я наконец-то понял почему.

У меня контекстное меню показывается "по клику" (Меню-Настройки)

И - легко вызывается, легко скрывается, жамком на любом месте на карте.

Попробовал поставить "по длительному нажатию" - 

долгим тапом включается, долгим и выключается. Надо нажать на карте тоже 1-2 секунды.

На ходу конечно непросто.

ИМХО правильнее, чтоб сбрасывалось всегда коротким тапом.

Share this post


Link to post
Share on other sites
7 минут назад, IШIN сказал:

А у меня такой проблемы нет... И я наконец-то понял почему.

У меня контекстное меню показывается "по клику" (Меню-Настройки)

И - легко вызывается, легко скрывается, жамком на любом месте на карте.

Попробовал поставить "по длительному нажатию" - 

долгим тапом включается, долгим и выключается. Надо нажать на карте тоже 1-2 секунды.

На ходу конечно непросто.

ИМХО правильнее, чтоб сбрасывалось всегда коротким тапом.

Спасибо! Поставил, попробую. 

Share this post


Link to post
Share on other sites
2 часа назад, IШIN сказал:

правильнее, чтоб сбрасывалось всегда коротким тапом

Если верить содержимому ленгпака, то на тап-меню установлен autohide 5 сек. Но он не работает. Так что, только повторным тапом. Или ждать пока "тапнутое"  место выйдет за пределы экрана, тогда меню пропадает.

Share this post


Link to post
Share on other sites
3 часа назад, fotolom сказал:

Если верить содержимому ленгпака, то на тап-меню установлен autohide 5 сек. Но он не работает. Так что, только повторным тапом. Или ждать пока "тапнутое"  место выйдет за пределы экрана, тогда меню пропадает.

С выходом за пределом экрана бывает вообще забавно из-за автомасштаба - едешь помедленнее - за экран выходит и пропадает, едешь побыстрее - снова попадает в экран. Так раздражает еще сильнее=))

Share this post


Link to post
Share on other sites
18 часов назад, IШIN сказал:

А у меня такой проблемы нет... И я наконец-то понял почему.

У меня контекстное меню показывается "по клику" (Меню-Настройки)

И - легко вызывается, легко скрывается, жамком на любом месте на карте.

Угу, у меня тоже по клику, а толку? Легко вызывается и то не всегда, а скрыть - стучишь, как дятел...

Я, кстати, в телефоне какую-то настройку поставил, чтоб на экране показывалось место нажатие. Т.е. нажимаешь на экран - под пальцем появляется затененный кружочек.Так вот, кружочки появляются, а реакции никакой. Т.е. вроде операционка, иль драйвер какой, нажатие отрабатывает, а до СГ не доходит или сам СГ дурит. Такая же хрень у меня была на texete610: жмешь по экрану, слышан щелчок от операционки, а звука нажатия от СГ не слышно и, естественно, ничего не происходит

Share this post


Link to post
Share on other sites



Угу, у меня тоже по клику, а толку? Легко вызывается и то не всегда, а скрыть - стучишь, как дятел...

Уууу, как у Вас все запущено. М.Шац
У меня все нормально в этом плане.
На СЕ - там да, нехватка мозгов оказывалась, реакции на тап можно было и полминуты ждать.

За ашыпки прашю венить Tapatalk

Share this post


Link to post
Share on other sites
3 часа назад, svlad2012 сказал:

Угу, у меня тоже по клику, а толку? Легко вызывается и то не всегда, а скрыть - стучишь, как дятел...

Я, кстати, в телефоне какую-то настройку поставил, чтоб на экране показывалось место нажатие. Т.е. нажимаешь на экран - под пальцем появляется затененный кружочек.Так вот, кружочки появляются, а реакции никакой. Т.е. вроде операционка, иль драйвер какой, нажатие отрабатывает, а до СГ не доходит или сам СГ дурит. Такая же хрень у меня была на texete610: жмешь по экрану, слышан щелчок от операционки, а звука нажатия от СГ не слышно и, естественно, ничего не происходит

По моим наблюдениям, СГ не понимает тычок в экран, если в этом месте на экране МОЖЕТ быть кнопка из его интерфейса. То есть если эта кнопка в настройках отключена, экран в данном месте на касания не реагирует. У меня отключено все, кроме "плюс-минус", так что в такие зоны я попадаю пальцем часто. Но тычок в центр экрана (где кнопок нет и быть не может) всегда убирает контекстное меню без проблем.

Да, это все про штатный скин, альтернативные никогда не пробовал.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×