Jump to content
GPS навигатор СитиГИД
NeoX

Новые знаки для Диспетчера

Recommended Posts

Нужна помощь.
Хочу в Диспетчер добавить знаки выезд/выезд в/из населенного пункта. 
Добавил картинки в лангпак, поправил ресурсник. При выборе знака я вижу название но не вижу картинки, но на самой карте знак отображается. 

tyraduhe.jpg

a4uzahu5.jpg

Как их правильно добавить?

Share this post


Link to post
Share on other sites

подозреваю что знак должен быть квадратным, а не длинным, поэтому и не отображается.

например в моих ресурсах и лангпаке здесь

та же самая проблема

добавленный знак движения по полосам отображается и в списке и на карте, а населенные пункты - только на карте.

На фоне всех других приколов диспетчера это такая мелочь, что я забил.

Share this post


Link to post
Share on other sites

нашел неожиданно решение

нужно:

последняя цифра в имени картинки должна быть 6

то есть например user096.bmp или user106.bmp

и нужно в файле PresTraf.xml (внутри resources.rsr) поменять соответсвующиее имя файла, чтоб были прописаны вышеуказанные

<obj CodeObj="18809"><!--USER09-->
      <par CodeMrk="36" ColorFor="0x858585"/>
      <var SclMin="0" SclMax="500000">
      <elem> <pict PictName="USER096.bmp"/> <txt/> </elem>
    </var>
  </obj>
  <obj CodeObj="18810"><!--USER10-->
      <par CodeMrk="36" ColorFor="0x858585"/>
      <var SclMin="0" SclMax="500000">
      <elem> <pict PictName="USER106.bmp"/> <txt/> </elem>
    </var>

 

последняя цифра указывает на используемую маску. Для длинных знаков должна стоять 6. Для квадратных - 1. Для круглых - 3

  • Upvote 2

Share this post


Link to post
Share on other sites

Попробую!

Спасибо!

Share this post


Link to post
Share on other sites

MonoRAil.kz,

Пока получил только вот такой результат!

 

 

 

Share this post


Link to post
Share on other sites

это странно.диспетчер, я смотрю, у нас одинаковый. знаки эти я сам рисовал, они подходят под маску как раз.

можете прислать или дать ссылку на файлообменник с лангпаком и ресурсами от вашего диспетчера? посмотрю, что у вас не так.

Share this post


Link to post
Share on other sites

MonoRAil.kz, ,

отправил ЛС!

Share this post


Link to post
Share on other sites

получил, посмотрел, все понял.

проблема в картинках. Используемые вами имеют глубину цвета 24 бита на пиксель, нужны - 16 бит на пиксель. Далеко не всякий графический редактор умеет такие делать.

http://forum.autoatlas.kz/index.php?/topic/7-

здесь лежат мои буквально вчерашние ресурсы и лангпак для диспетчера, полностью адаптированные под работу со спидкамом для 7.7 -7.8, помимо значков там много чего исправлено.

Значки отображаются. Тоже не совсем хорошо, черный квадрат все же немного выпирает по краям. Но картинка имеется.

Попробуйте.

Если не понравится - можете оттуда картинки просто выдрать, там они правильного формата.

Edited by MonoRAil.kz

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×